HTTP Status
约 2 分钟阅读
Status
| status | name | note |
|---|---|---|
| 100 | Continue | |
| 101 | Switching Protocols | |
| 102 | Processing | |
| 103 | Early Hints | |
| 200 | OK | |
| 201 | Created | |
| 202 | Accepted | |
| 203 | Non-Authoritative Information | |
| 204 | No Content | |
| 205 | Reset Content | |
| 206 | Partial Content | |
| 207 | Multi-Status | |
| 208 | Already Reported | |
| 226 | IM Used | |
| 300 | Multiple Choices | |
| 301 | Moved Permanently | |
| 302 | Found | |
| 303 | See Other | |
| 304 | Not Modified | |
| 305 | Use Proxy | |
| 306 | Switch Proxy | |
| 307 | Temporary Redirect | |
| 308 | Permanent Redirect | |
| 400 | Bad Request | |
| 401 | Unauthorized | |
| 402 | Payment Required | |
| 403 | Forbidden | |
| 404 | Not Found | |
| 405 | Method Not Allowed | |
| 406 | Not Acceptable | |
| 407 | Proxy Authentication Required | |
| 408 | Request Timeout | |
| 409 | Conflict | |
| 410 | Gone | |
| 411 | Length Required | |
| 412 | Precondition Failed | |
| 413 | Request Entity Too Large | |
| 414 | Request-URI Too Long | |
| 415 | Unsupported Media Type | |
| 416 | Requested Range Not Satisfiable | |
| 417 | Expectation Failed | |
| 418 | I'm a teapot | |
| 419 | CSRF Token Missong or Expired | unofficial |
| 419 | Page Expired | unofficial |
| 420 | Enhance Your Calm | unofficial |
| 421 | Misdirected Request | |
| 422 | Unprocessable Entity, Unprocessable Content | |
| 423 | Locked | |
| 424 | Failed Dependency | |
| 425 | Too Early | |
| 426 | Upgrade Required | |
| 428 | Precondition Required | |
| 429 | Too Many Requests | |
| 431 | Request Header Fields Too Large | |
| 440 | Login Time-out | unofficial |
| 444 | No Response | unofficial |
| 449 | Retry With | unofficial |
| 450 | Blocked by Windows Parental Controls | unofficial |
| 451 | Unavailable For Legal Reasons | |
| 460 | Client closed the connection with AWS Elastic Load Balancer | unofficial |
| 463 | The load balancer received an X-Forwarded-For request header with more than 30 IP addresses | unofficial |
| 494 | Request header too large | unofficial |
| 495 | SSL Certificate Error | unofficial |
| 496 | SSL Certificate Required | unofficial |
| 497 | HTTP Request Sent to HTTPS Port | unofficial |
| 498 | Invalid Token (Esri) | unofficial |
| 499 | Client Closed Request | unofficial |
| 500 | Internal Server Error | |
| 501 | Not Implemented | |
| 502 | Bad Gateway | |
| 503 | Service Unavailable | |
| 504 | Gateway Timeout | |
| 505 | HTTP Version Not Supported | |
| 506 | Variant Also Negotiates | |
| 507 | Insufficient Storage | |
| 508 | Loop Detected | |
| 509 | Bandwidth Limit Exceeded | |
| 510 | Not Extended | |
| 511 | Network Authentication Required | |
| 520 | Web Server Returned an Unknown Error | Cloudflare |
| 521 | Web Server Is Down | Cloudflare |
| 522 | Connection Timed Out | Cloudflare |
| 523 | Origin Is Unreachable | Cloudflare |
| 524 | A Timeout Occurred | Cloudflare |
| 525 | SSL Handshake Failed | Cloudflare |
| 526 | Invalid SSL Certificate | Cloudflare |
| 527 | Railgun Error | Cloudflare |
| 530 | Origin DNS Error | |
| 561 | Unauthorized (AWS Elastic Load Balancer) |
- RFC 7231
- 502,503,504,505
- RFC 7235
- 401, 407
- RFC 2295
- 506
- RFC 4918
- 507
- 403 Forbidden
- 一般用于无权限,也用于需要认证 WWW-Authenticate
- 406 Not Acceptable
- Accept 头不匹配
- Nginx
- www.nginx.com/resources/wiki/extending/api/httpLinkwww.nginx.com/resources/wiki/extending/api/http| status | name | note | · | 100 | Continue | · | 101 | Switching Protocols | · | 102 | Processing | · | 103 | Early Hints |笔记:HTTP Status
- Wikipedia:List of HTTP status codesWikipediaList of HTTP status codes
- developers.cloudflare.com/support/troubleshooting/cloudflare-errors/troubleshooting-cloudflare-5xx-errors
- httpstat.us
关联信息
反向链接、本文链接的其他页面和外部资料。
References
Wikipedia1 条
- List of HTTP status codesWikipedia:List of HTTP status codes
其他外链3 条
- developers.cloudflare.com/support/troubleshooting/cloudflare-errors/troubleshooting-cloudflare-5xx-errorsdevelopers.cloudflare.com/support/troubleshooting/cloudflare-errors/troubleshooting-cloudflare-5xx-errors
- httpstat.ushttpstat.us/
- www.nginx.com/resources/wiki/extending/api/httpwww.nginx.com/resources/wiki/extending/api/http